Symptom
You notice an application error in Web Service Message Monitoring, for the service interface EmailServiceRequestIn with the error message Please enter a party with role Owner.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Administrator work center.
- Navigate to Web Service Message Monitoring.
- Search for the Message ID of the erroneous entry, under EmailServiceRequestIn interface.
- See the error Please enter a party with role Owner.
Cause
The system cannot create the e-mail activity in the system because the party Owner was marked as mandatory and the determination for the role was configured in a way that it does not work for incoming e-mails.
Resolution
In such scenario, you can follow the steps below:
- Navigate to Business Configuration work center.
- Navigate to Overview view.
- Look for and open the Activity for Activities filter.
- Choose the hyperlink to keep involved parties for e-mails.
Here you can see which roles are marked as mandatory and you can check the automatic determination of each party and uncheck the mandatory rule.
Keywords
Please enter a party with role Owner, Party, Owner, Role, Error Message, Error, Web Service Message Monitoring, EmailServiceRequestIn, Interface, Service Interface, Service, E-mail, C4C, Ticket, , KBA , LOD-CRM-SRP , Service Request Processing , How To