Symptom
When users try to create process id in MDG app "Manage Mass Maintenance - Products" system hangs for long time and users are unable to continue the process id.
Environment
SAP S/4 HANA Cloud
Reproducing the Issue
- Login to MDG Fiori launchpad.
- Open App Manage Mass Maintenance - Products.
- Create Process id.
- System hangs for long time.
Cause
Improper user handling.
Resolution
Please note that when trying to upload a file using Office Open XML (For example, created by Microsoft Excel), the data amount could be very high and requires memory on the application server. When the memory limit is reached, there will be an error. You should not upload large amounts of data using Office Open XML format (recommendation: not more than 5.000 records per file). For larger volumes, please load separate files or use a compressed CSV file format to save memory.
For more information, see the following FAQ:
https://www.sap.com/documents/2021/09/4aa709b7-f77d-0010-bca6-c68f7e60039b.html
Keywords
MDG Consolidation, Performance, Process id, Stuck, Hang, Manage Mass Maintenance, Product. , KBA , CA-MDG-CMP-FIO , Fiori UI for Consolidation & Mass Processing , Problem