Symptom
Simple Product Attribute is not showing in the shopping cart.
Environment
Type: Productive and Test System
Product version: CPQ 2022
System managed by: SAP Cloud Tenant
Sold product: SAP CPQ Cloud
Reproducing the Issue
- Add a Simple Product that contains an Attribute of "User Selection" type to the Shopping Cart;
- Using Script or CTX Tag, try to check for the attribute values;
- Attribute of User Selection Type, it will not appear.
Cause
As simple Products do not pass through Configurator screen, if attribute has multiple values and none is marked as Preselected, attribute will not be shown in Cart Page.
Resolution
If the attribute is of User Selection type, a value must be marked as preselected on Product Configuration in Setup.
If attribute has multiple values, there must be one marked as preselected in order to be shown in the Shopping Cart.
See Also
Simple Product - https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/cac2c6afff924bb4b4ea19eefedb695c.html;
Keywords
Simple Product, Attribute Value, Attribute, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem