Symptom
In project assignment rules, for some lines, the service is fulfilled with asterisk (*) and some lines, the service is automatically fulfilled with ID.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Project Management work center.
- Go to Not Invoiced Time and Expenses view.
- Search for the affected project.
- Click Edit Time and Expenses button.
- Click Edit All Rules > View All Rules button.
- You would like to know why sometimes system creates the standard rules with the selection of a certain service and sometimes without - asterisk(*).
Cause
In general, the system creates the assignment rules as generic as possible and as specific as needed.
If all the sales order items are assigned to a different project task. Thus, the project task identifies uniquely also the related service. It is not needed to specify the service explicitly in the assignment rules. It displays as asterisk (*) under Service column.
If all the sales order items are assigned to the same project task. Thus, there is an additional criterion needed to identify the assignment uniquely, i.e. the service. It is fulfilled with the certain service ID accordingly.
If the project has multiple sales orders assigned, which makes it different in this case. Here, the system is also a bit more specific and includes the service as a criterion in the assignment rules.
Resolution
System is working as designed.
Keywords
Project Assignment Rules, Service, Not Invoiced Time and Expenses, Asterisk (*) , KBA , SRD-PRO-PMN , Project Management , Problem