SAP Knowledge Base Article - Public

3285105 - Screen Size is limited by a gray bar when landing on CPQ in SalesForce

Symptom

When creating a quote from SFDC and navigating to CPQ screen size is limited by a gray bar. 

Environment

Type: Test and Productive System 
Product version: SAP CPQ 2022
System managed by: SAP Cloud Tenant
Sold product: SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Go to Salesforce;
  2. Create a Quote;
  3. Land on CPQ page and see a gray bar limiting screen size.

Cause

Configuration should be sustained on salesforce side.

Resolution

As IFrame is sustained from Salesforce Side, it is possible to override configuration on Salesforce, removing screen size limitation.
On the following help article,  https://help.sap.com/docs/SAP_CPQ/f80fbcd4f1c74232839c30ce26886f07/c58146fa0ace423fba8ad51ca871e051.html, it is possible to find examples on how to create NewQuote/EditQuote in Salesforce.
It is possible to modify the parameter called maxHeight, which is responsible for setting the height of the CPQ page when placed in Salesforce iFrame.

There are no settings on CPQ side that can modify this parameter from Salesforce iFrame.

See Also

Salesforce Integration Instruction - https://help.sap.com/docs/SAP_CPQ/f80fbcd4f1c74232839c30ce26886f07/c58146fa0ace423fba8ad51ca871e051.html.

Keywords

SFDC, Salesforce, Screen size, gray bar, screen size limitation, CPQ. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ 2020

Attachments

Salesforce Integration Instruction.png