Symptom
- Instance Refresh Tool got stuck in "Scheduled" status, and the refresh didn't run in the scheduled time.
- Instance Refresh tool fails with the following message in the IRT logs: TENANTREFRESH_UNKNOWN_VALIDATION_ERROR.
- (CPS team) Simultaneously, on the application logs on Splunk we can see one of the following entries:
- Failed to serialize validation info sf_class=com.successfactors.appsec.AbstractAccessController [...]
- Failed to initialize job context for AbstractJobContextJanitor [...] Caused by: com.successfactors.maestro.ProcessEngineException: Specified service task user identity [ xxxxx] doesn't exist!
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Cause
- Scenario 1: Business Process Engine (BPE) is not enabled in the target instance or is misconfigured.
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Scenario 2: JWT Token validation issue while executing the Refresh Request Redo Validation Activity. Underlying issue with Clock.
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Scenario 3: Temporary network disruption while executing the validation job.
Resolution
Scenario 1:
As part of IRT prerequisites, Business Process Engine (BPE) should be enabled in the source system's Provisioning as per KBA 2791468.
There is an implemented functionality in IRT to check whether BPE is enabled or not in the Target system. This functionality also takes care of enabling it if necessary during the validation activity.
However, if you face one of the symptoms described above, it might happen that the BPE was not enabled in one of the processes or is misconfigured. To fix this, please engage your authorized Partner or report this to Customer Support via support case. They will follow the steps bellow to fix the BPE.
Partner/CPS:
- Go to Provisioning
- Under Company Settings search for "Enable Business Process Engine"
- Enable the BPE and set the default option "Use ProcessJob Identity"
- If the "Specific User Identity" is kept for any particular reason, a valid username must be provided (make sure there are any space staring and ending of that user id, the exact active user id has to be entered).
See the default configuration in the image below:
Note: We highly recommend keeping the "Use ProcessJob Identity" option enabled in BPE. By default, this option utilizes an internal system user, ensuring that any potential issues in IRT caused by the admin user data are avoided.
Scenario 2 and 3:
As a sporadic and intermittently issue, we suggest the customer to perform a new refresh attempt using the IRT Tool. If the error persists, please request for a Manual Refresh 2277508 - SuccessFactors Cloud Manual Instance Refresh Process & FAQ - SAP for Me
CPS team please check the Internal Memo for scenario 3.
See Also
Keywords
sf, sfsf , sf sf, SuccessFactors, SuccessFactor, Success, Factor, bizx, Instance refresh, TENANTREFRESH_UNKNOWN_VALIDATION_ERROR, enabling bpe feature on target instance, TLS-26589, INC3483745, INC3441872, 2H 2022, INC6449649 , KBA , LOD-SF-PLT-IRT , Instance Refresh Tool , Problem