SAP Knowledge Base Article - Public

3285499 - How to Create User-Defined Filter in C4C to Use in Server-Side Integration

Symptom

Customer is wondering why personalized queries from Contacts OWL don't appear under the add-in.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Access the E-mail Integration WC
  2. Open User Settings View
  3. Go to Sync Settings
  4. Open Detailed Settings
  5. Click on Customize

Cause

User Defined Filters can be set only by a key-user.

Resolution

How to set up:

  1. Log-in to C4C as key user.
  2. Open target record type, where custom filter should be created, e.g. "Accounts".
  3. Go to "Adapt> Edit Master Layout.
  4. Click "Show Advanced Filter" and adjust filter settings according to your needs.
  5. Click "Save Query" add a name.
  6. Go to "Adapt" > "End layout changes".
  7. Go to 'Email Integration> Groupware settings. Profiles".
  8. In "Sync Settings" tab, created filter will be displayed in "User-Defined Filters" section.
  9. To apply profile changes for all users, make sure to open Organization and click "Save and apply profile for all users" in menu options.

The Server Side integration supports user defined filters, which can be created in C4C and used for filtering a scope of records, that are synchronized from C4C into Exchange\Gmail. User defined filters are supported for the following record types:

  • Contacts
  • Accounts
  • Individual Customers
  • Tasks

See Also

SAP Help Portal Server-Side Integration for Microsoft Outlook

Keywords

Personalized; Queries; Appear; Add-in; Create; User; Define; Filter; Server-side; Key user; Profiles; Sync Settings; custom filters; objects; restrict sync; Visits; type; built-in filters; , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2211