Symptom
When opening a quote from C4C, generic Application Error is thrown.
In LogEvent, record with "Message: Argument 'Response body is empty !' can not be null".
Environment
SAP SALES CLOUD CPQ connected with Cloud for Customer
Reproducing the Issue
- Open Cloud for Customer environment;
- In Sales Quote, try to expand a quote and open it on CPQ;
- Quote will load and throw a generic Application Error.
Cause
REST API base URL address provided is not correct.
Resolution
Mentioned field should be populated with URL provided after iFlow is deployed in CPI. To check this, user should go to "Manage Integration Content" page on CPI and enter configuration of proper iFlow. On expanded page, the URL will be displayed along with endpoint.
See Also
- SAP Cloud for Customer Integration - https://help.sap.com/docs/SAP_CPQ/f80fbcd4f1c74232839c30ce26886f07/397d0ee88d01475b8c3ffc210e5946c7.html?version=latest
- Enable the Integration with SAP Cloud Integration - https://help.sap.com/docs/SAP_CPQ/c4181507d73142359dd93185ca61b726/9138acc59f5347fa8d04f3b8e928c871.html?version=latest
Keywords
Integration, C4C, CPI, Application Error, Cloud for Customer, Cloud Integration, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed