SAP Knowledge Base Article - Public

3285665 - Work center Organization Based On Business Role Assignment

Symptom

When the user has "A" and "B" roles assigned, the work center organization only works for the "A" role, and no longer for "B".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login with user that has "B" role.

  2. Notice the number of available WC view under Administrator for role "A".

  3. Now, login with a user who has the role "B" and also "A" assigned.

  4. You can see that other work center are shown in addition. 

Cause

  1. If a user has more than one business role assigned, then the first role alphabetically takes precedence. Example: I have a user who has business roles A (which is assigned list 1) and business role B (which is assigned list 2). In this case, list 1 will be predominant as alphabetically A precedes B.
  2. If a user with multiple business roles has different organized work center view names assigned, then the system uses the union operation to hide or show the work center and work center views. 
  3. If you have assigned an organized work center and work center view to a role and another one to the master layout, then the role specific one takes precedence. 

Resolution

Adjust business role assignment having the above system design into consideration. Nevertheless, keep in mind that having multiple role assignment is not a recommended practice since it can lead to several mismatch scenarios.

See Also

Blog - Organize Work Centers and Work Center Views in C4C

Keywords

User; Roles; Assigned; Work Center; Organization, Views; Inconsistencies. , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2211