SAP Knowledge Base Article - Public

3286215 - It is not possible to trigger multiple workflows for one action - Employee Central

Symptom

Several business rules are configured in Manage Business Configuration HRIS Elements to trigger workflows, such as jobInfo element. Trigger business rules by adding new record via Pencil Icon. According to rule trace logs, the workflows are set successfully, however, actually only one workflow is generated.

Environment

 SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Create multiple business rules to set workflow
  2. Configure these rules in Manage Business Configuration
  3. Click Pencil icon in people profile to trigger business rules
  4. Check rule trace logs, the workflows are set successfully
  5. Only one workflow is finally triggered

Cause

This works by system design. Only the last workflow triggered as 'set' in rule trace logs is triggered for the action.

Please note: for CC role-only workflow, this order may vary.

Resolution

Since this works by design, there is no way to trigger multiple workflows for one action. If you find more than one workflow in the rule trace, please adjust the rules to have only one workflow triggering per transaction.

If you wish to request this feature, please log an idea with the Product Management team by following the instructions in the KBA 2090228 - How to Submit Ideas for SAP SuccessFactors Products

See Also

Keywords

 business rules, rule trace logs, multiple workflows, workflows, one workflow, trigger multiple workflows, how to trigger workflows, cc role, many workflows, two workflows, transaction, business rule, rule trace , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC-WFL-REQ , My Pending Requests, ToDo's & Mass Approvals , LOD-SF-EC-CMP-RUL , Business Rules , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions