SAP Knowledge Base Article - Public

3286306 - Ticket History Data Source Shows Incomprehensible Entries

Symptom

You are viewing the Ticket History data source (SEODSRQHHB) or a report based on it. You are reviewing changes done to specific tickets. For example, let us take the "Status" characteristic. You add the fields Status, Start Date and End Date to the view.

You can see the different status of the ticket with the corresponding time stamps, however you may also see the same status for different time stamps, for example status A for 01.01.2022 to 10.01.2022 and then again status A from 10.01.2022 until now. You are wondering why there are separate entries even though the status was not changed on Jan 10th.

Environment

SAP Cloud for Customer

Cause

The characteristics "Start Date" and "End Date" are not based on the "Status" of each ticket or any attribute of the ticket specifically. Instead, such fields collect the timestamp of each change made in ticket, working more as a "validity info".

Repeated lines like this usually refer to another change that was made to a different ticket attribute at the same time.

Resolution

In our example outlined above, there was another change of this ticket on Jan 10th (for example the ticket priority). Since the status was not changed, the data source will show a change time stamp but the same status as before.

This is the correct behavior for this data source.

Keywords

ticket history, duplicate entries, wrong content, wrong data, missing, data source, business analytics, reporting, redundant entries , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications all versions