SAP Knowledge Base Article - Public

3286382 - Error 'Previous Action Failed; Inconsistent Data Cannot Be Saved' Occurs When Creating Cash Payments Through Web Service ManageCashPaymentOrderIn

Symptom

You create an on account incoming cash payment ABC(ABC represents the ID of the payment) through web service ManageCashPaymentOrderIn. Error 'Previous action failed; inconsistent data cannot be saved' occurs when requesting. No cash payment is cretaed.

You check the upload payload and no inconsistency is found. You expect that an on account payment ABC will be created to the account of the entered BusinessPartnerID DEF(DEF represents the BusinessPartnerID in the payload).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. You request through web service ManageCashPaymentOrderIn in SOAPUI to create an on account incoming cash payment.
  2. After requesting, no cash payment is created.
  3. And you receive an error message 'Previous action failed; inconsistent data cannot be saved'.

Cause

One of the reasons that this error could occur while creating an incoming cash payment via webservice is that there is only 1 credit memo open in the customer account.

Resolution

You need to make sure there is not just one open credit memo.

Alternatively, you can propose a clearing for this credit memo through manual clearing first. By this, this credit memo would not be picked while creating the incoming cash payment.

Steps as follows:

  1. Go to the Receivables work center.
  2. Find the Customer Account DEF(DEF represents Customer Account).
  3. Choose the Customer Account and Choose View.
  4. Go to Trade Receivables view and then to Invoices/Payments Subview.
  5. Select the uncleared credit memo and click 'Clear Manually'.
  6. Enter the required data and save.

Keywords

Web Service, ManageCashPaymentOrderIn, Incoming Cash Payment , KBA , SRD-FIN-MOP , Payment Management , Problem

Product

SAP Business ByDesign all versions