Symptom
Create an on account incoming cash payment ABC(ABC represents the ID of the payment) through web service ManageCashPaymentOrderIn. Error 'Previous action failed; inconsistent data cannot be saved' occurs when requesting. No cash payment is cretaed.
Check the upload payload and no inconsistency is found. It is expected that an on account payment ABC will be created to the account of the entered BusinessPartnerID DEF(DEF represents the BusinessPartnerID in the payload).
Environment
SAP Business ByDesign
Reproducing the Issue
- Request through web service ManageCashPaymentOrderIn in SOAPUI to create an on account incoming cash payment.
- After requesting, no cash payment is created.
- And receive an error message 'Previous action failed; inconsistent data cannot be saved'.
Cause
One of the reasons that this error could occur while creating an incoming cash payment via webservice is that there is only one credit memo open in the customer account.
Resolution
Make sure there is not just one open credit memo.
Alternatively, it is possible to propose a clearing for this credit memo through manual clearing first. Then this credit memo would not be picked while creating an incoming cash payment.
Steps as follows:
- Go to the Receivables work center.
- Find the Customer Account DEF(DEF represents Customer Account).
- Choose the Customer Account and Choose View.
- Go to Trade Receivables view and then to Invoices/Payments Subview.
- Select the uncleared credit memo and click 'Clear Manually'.
- Enter the required data and save.
Keywords
Web Service, ManageCashPaymentOrderIn, Incoming Cash Payment , KBA , SRD-FIN-MOP , Payment Management , Problem
SAP Knowledge Base Article - Public