SAP Knowledge Base Article - Public

3287337 - Unable to see all addresses in table report - Employee Central

Symptom

While creating a table report for Person and Employment data, addresses with ID greater than 10 are not being displayed. 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Configure fields greater than address10 in homeAddress for any country in Manage Business Configuration
  2. Go to reports center
  3. Create a table report for Person and Employment
  4. Search for the fields (address11, address12 etc.)
  5. Fields are not available

Cause

This is an expected behavior. It is only possible to report until address10 in table report.

Resolution

Use SAC report to get specific home address for all fields configured in the instance.

PS: Since in Ad-Hoc report there is no separate CSF HomeAddress views for selection of specific columns of multiple types of configuration under differenct countries. Say address3 is defined for many countries with different setup, then you can use advanced reporting/SAC to pull up the data needed for a specific country.

See Also

2080162 - Employee Central - Ad-Hoc Report Types & Permissions Explained

Keywords

table report, address, homeAddress, report center , KBA , LOD-SF-EC-REP , Reporting Data (EC core only) , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions

Attachments

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