SAP Knowledge Base Article - Public

3287526 - External ID and Original External ID are not copied to the Phone Call Activity

Symptom

  • You expect the External ID (ExternalReferenceID) and the External Original Reference ID (ExternalOriginalReferenceID) to be copied to the Phone Call Activity Header after the corresponding phone call pay load is passed C4C
  • Although both ExternalReferenceID & ExternalOriginalReferenceID can be seen in the Live Activity Center Call Information View, the same are blank in the phone call activity header

Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service
  • SAP Cloud for Sales
  • Live Activity

Reproducing the Issue

  • Assuming you are using the CTI Local Adapter (simulating the call using CTI Adapter)
    1. Open the CTI adapter
    2. Click Simulate
    3. Fill the Phone number in the Dialing from field
    4. Click Simulate
    5. Enter a Value like ABC123DFG456 in the External ID field + Type=Inbound, then click "Simulate" 
      Simulate_CTI.png
    6. Accept the call by clicking on the pop-up
    7. Go to Activities, Phone Calls
    8. Open the corresponding activity and expand the Header details. 
  • If using a CTI widget:
    1. Connect to the Widget from C4C
    2. Accept an incoming call (the CTI provider should send the correct payload per the "Phone Events and Payload" documentation)
    3. Go to Activities, Phone Calls
    4. Open the corresponding activity and expand the Header details

Cause

  • Missing configuration
  • Passing the parameters require maintaining the "Comm. System ID"

Resolution

  • Ensure the payload sent by the CTI conforms to the correct specification
  • Ensure the  "Comm. System ID" is correctly defined
    1. Go to Administrator
    2. Click "Service and Social"
    3. Navigate to and client on "Live Activity Configuration"
    4. See under Fiori Client Settings, and enter a value in the "Comm. System ID" field. For example, "Contact_Center".
      LiveActivity_Config.png
  • The Comm. System ID can then be maintained under the "Communication Systems" using the following steps:
    1. Go to the Administrator work center
    2. Select the General Settings view
    3. Open Communication Systems
    4. If there was no Comm. System ID, then create a one
    5. Click "New"
      1. Under "Basic Information", enter the "ID" (for example, Contact_Center), "Host Name = Contact_Center" and "System Type = Internet"
        CommSystem1.png
      2. Go to System Instances and click "Add Row"
      3. Enter System ID = Contact_Center and Preferred Application Protocol = 5 - Web Service
        System_Instances.png
      4. Go to Actions -> Activate
      5. Click "Save and Close"
        • If there was already one created, then ensure that the ID is exactly the same as what was defined in the Live Activity Configuration AND "In Use" field is enabled
        • Specially the System Instance ID, which in this example is "Contact_Center"
        • It is important that both the Communication System ID and the Business Instance ID are the same as the one maintained on the Live Activity Configuration

See Also

2803384 - UpdateActivity Event in CTI adapter is not updating the changes in the Activity

Keywords

External Reference ID, Original Reference ID, Copied, Live Activity, Phone Call Activity

 
, KBA , live activity , original external id , comm systems id , external id , externalreferenceid , externaloriginalreferenceid , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer core applications 2211