Symptom
You have created an extension field in sales order and activated below extension scenarios:
- Sales Order - General Information to Outbound Delivery Request - General Information
- Outbound Delivery Request - General Information to Warehouse Request - General Information
- > Outbound Delivery Request - General Information to Warehouse Request - Item
- > Outbound Delivery Request - General Information to Warehouse Request - General Information
Then you create a new sales order, maintain value for the extension field and then proceed the process until warehouse request created. However, the value of this extension field was brought to business context "General Information to Warehouse Request - General Information", not brought to business context "General Information to Warehouse Request - Item".
Environment
SAP Business ByDesign
Reproducing the Issue
Prerequiste: in any existing sales order, under tab General, open Adapatation Mode, create a new extension field "EXT" (type: Extended Text) and extend it to below scenarios:
- Sales Order - General Information to Outbound Delivery Request - General Information
- Outbound Delivery Request - General Information to Warehouse Request - General Information
- > Outbound Delivery Request - General Information to Warehouse Request - Item
- > Outbound Delivery Request - General Information to Warehouse Request - General Information
- Create sales order ABC (ABC represents sales order ID), maintain value“EXT1" for extension field "EXT" under tab General; then release the sales order to customer demand and then release to delivery proposal.
- In delivery proposal DEF (DEF represents delivery proposal ID), under tab General, you can see the same content in extension field "EXT" (business context: Outbound Delivery Request - General Information). Click Create Warehouse Request against delivery proposal DEF, warehouse reques XYZ (XYZ represents warehouse request ID) created.
- Go to work center Outbound Logistics, open view Warehouse Requests, find warehouse reques XYZ, click the ID directly, you can see it is blank in "EXT" (business context: Warehouse Request - Item).
- However, go to work center Outbound Logistics, open view Warehouse Requests, find warehouse reques XYZ, click Edit, under tab General, you can find "EXT" has value (business context: Warehouse Request - General Information).
Cause
Extension scenario "Outbound Delivery Request - General Information -> Warehouse Request - General Information" has below 2 sub scenarios:
- Outbound Delivery Request - General Information to Warehouse Request - Item
- Outbound Delivery Request - General Information to Warehouse Request - General Information
We have 2 sub scenarios to cover the merge scenarios from ODR (outbound delievery request) to SLR (site logistics request, i.e. warehouse request). For example, we have ODR1 and ODR 2, both have extension field "EXT" with values "EXT1", "EXT2" respectively. If we merge ODR1 and ODR2 to create SLR1 and above Extension Scenarios are active, then system will copy ODR1 extension field data to SLR1 and then ODR2 to SLR1. In this process, extension field value is getting overwritten due to merge case, so we have sub scenario which will extend the same extension field to SLR1-Item level so that items will get values from their corresponding ODRs.
Hence, extension scenario "Outbound Delivery Request - General Information -> Warehouse Request - Item" only works in merging case, otherwise they can have the extension field on Warehouse Request - General Information which will work.
Resolution
This is system standard behavior.
Keywords
Sales Order, Warehouse Request, Extension Field, General Information, Item , KBA , AP-ODP-ODR , Outbound Delivery Request , Problem