Symptom
When you try to sort the column "Channel ID" on Tickets OWL screen, the sort does not work properly.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Service then Tickets WoC view.
2. On table search for Channel ID field.
3. Set the sorting to Ascending.
4. Observe that the order is changed, but not for Ascending.
5. Set the sorting to Descending.
6. The behavior is the same and doesn't change.
Cause
The field is not getting sorted because it is a dedicated field.
The framework does not support sort for dedicated fields.
Resolution
This is a limitation.
See Also
Dedicated field means - such fields that would be present in the data model of the UI component but they would not be bound to any field at the BO level.
Usually these fields will be assigned to values based on some application specific code.
Such fields are also usually used for some calculation purpose or may be used to control visibility and other properties of other fields.
Keywords
Channel, ID, Sort, Field, Dedicated, Order, Correctly, Ascending, Descending, Sorting , KBA , AP-RC-UIF-RT-BE , UI Framework Runtime - Backend Components , How To