SAP Knowledge Base Article - Public

3289090 - Phone call activity not generated after receiving a phone call in Cloud for Customer system

Symptom

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service
  • SAP Cloud for Sales

Reproducing the Issue

  1. Connect to tenant
  2. Initiate an inbound call

Cause

  • Configuration
  • 3rd party issues
  • Missing payload

Resolution

  • Check that the Communication System ID is defined correctly in two places:
    • Comm. System ID defined in the Live Activity Configuration 
      1. Go to Administrator -> Service and Social
      2. Under Comm. System ID, enter something like Contact_Center (or anything else, which will be used later to define the Communication System)
    • Communication Systems
      1. Go to Administrator -> General Settings
      2. Under "Integrations", select "Communication Systems"
      3. Click "New" 
      4. Under Basic Information, enter the following (example)
        • ID= Contact_Center (or whatever was entered above in step 2 (Live Activity)
        • Host Name= enter the host name of the CTI
        • System Access Type= Internet
        • Fill the other fields as needed
      5. Scroll down to "System Instances" and click "Add Row"
        • Under System Instance ID enter "Contact_Center" or whatever was defined in step 2 for the live activity configuration (it must be exactly the same/case sensitive)
        • Under Preferred Application, select "5- Web Service"
      6. Go to "Actions" -> "Set to Active"
      7. Save and Close
  • If the above has been defined and there are still issues, then please ensure that the CTI provider is sending the correct payload require

See Also

  • 3156554 - CTI Integration Options with SAP Cloud for Customer (Service and Sales)
  • 3267127 - How does the CTI Call Flow work with Live Activity
  • 3287526 - External ID and Original External ID are not copied to the Phone Call Activity
  • 3141872 - Phone number in the Customer Hub or in the Phone Call Activity is empty when confirming caller during inbound call

Keywords

UpdateActivty, CTI, Local Adapter, Phone Call, Activity, phone number, Live Session, , KBA , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer core applications 2211