SAP Knowledge Base Article - Preview

3289620 - Could Not Execute Search after solr version downgrade

Symptom

After a release was deployed, which was build with lower solr version than the one which was present in the release deployed previously, a solr collection is marked as “Down” in Solr Admin Console and one cannot execute search.

 

There are errors being logged like the following, pointing to issues with solr core:

org.apache.solr.common.SolrException: Error opening new searcher

org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource BufferedChecksumIndexInput(MMapIndexInput(path="/var/solr/master_backoffice_backoffice_product_flip_shard1_replica_n1/data/index/segments_2"))): 10 (needs to be between 7 and 9)

o.a.s.c.CoreContainer Error waiting for SolrCore to be loaded on startup => org.apache.solr.common.SolrException: Unable to create core [master_backoffice_backoffice_product_flip_shard1_replica_n1]

Reindexing of collection fails with errors pointing to solr core being in “Down” state:

"Could not export configuration for index: name=master_backoffice_backoffice_product_flip","name":"de.hybris.platform.solrfacetsearch.solr.exceptions.SolrServiceException","cause":{"commonElementCount":30,"localizedMessage":"Could not find a healthy node to handle the request."


Read more...

Keywords

solr downgrade, format not supported , KBA , CEC-COM-CPS-SER , Search , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.