SAP Knowledge Base Article - Public

3290012 - How to Restrict Access to Business Partner Bank Details in SAP S/4HANA Cloud

Symptom

How to Restrict Access to Business Partner Bank Details in SAP S/4HANA Cloud

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open a Business Partner
  2. Bank details are visible to the user

Cause

Only the Business Partner Fiori Apps allow Bank Details to be hidden fully e.g. Manage Business Partner Master Data. The bank detials cannot be fully hidden in the BP GUI app called Maintain Business Partner Master Data

* For Employee BPs, access can be restricted using SENSTVT (Sensitivity) restriction which will mask Employee Bank details which were created via one the of HCM methods e.g. Bank Data created in the connected SF system or Bank Details coming from the Manage Workforce app. Employee Bank details created in S/4HANA Cloud e.g. in the Maintain or Manage Business Partner apps will not be hidden by the SENSTVT (Sensitivity) restriction.

Resolution

  1. Assign the user the catalogue SAP_CMD_BC_BP_APP_MAINT_PC for access to the Manage Business Partner App
  2. Set the "Country/Region Key of Bank" restriction type to be blank (no access) or set it to be "<Not maintained>"
  3. The user assigned this will now be able to view BPs in the Manage Business Partner app but will not be able to view the Bank Data.

Keywords

SAP S/4HANA Cloud, S4_PC, S4_1C, X4BC, S4HC, S/4HC, Bank, Restrict, Hide, SAP_CMD_BC_BP_APP_MAINT_PC, SAP_CMD_BC_CUST_MAINT_PC, SAP_CMD_BC_SUPP_MAINT_PC, SAP_CMD_BCG_BP_MAINT_PC , KBA , LO-MD-BP , Business Partners , AP-MD-BP , Business Partner , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions