SAP Knowledge Base Article - Public

3290099 - How to capture and export trace logs in Chrome or MS Edge as HAR files

Symptom

  • The SAP Support team has requested a copy of the browser trace logs in HAR format after an issue has been reproduced
  • This file can them be imported by the processor, where SAP can perform further analysis or an issue

Environment

  • SAP Cloud for Service
  • SAP Cloud for Customer
  • Live Activity
  • Agent Desktop
  • Microsoft Edge Browser
  • Google Chrome Browser

Cause

  • An HTTP Archive Format (HAR) file tracks and keeps logs of the web browser's interaction with a website.
  • If a reproducible error C4C or the Agent Desktop, a.har file can be used to help troubleshoot the issue.
  • The HAR file can also be used to troubleshoot performance issues.

Resolution

  • Using HTTPWatch
    1. Download free version at https://www.httpwatch.com/download/
    2. Check KBA 1431064 or https://help.httpwatch.com/gettingstarted.html
    3. Export to HAR
  • Using Edge:
    1. Connect to the tenant
    2. Press F12 to open the debug pane (ensure there are no additional tabs running in the browser window)
    3. Clear the session history before reproducing
    4. Press the play button at the top left of the debug pane to start recording
    5. Reproduce the issue
    6. Press the red square to stop recording
    7. Export the results as a HAR file by pressing the save button that is identified as a floppy disk
  • Using Google Chrome:
    1. While in the affected screen, right-click in the browser window or tab and select "Inspect" or press Ctrl+SHIFT+I (shortcut)
    2. Click the Network tab in the panel that appears
    3. Click the checkboxes Preserve log and Disable cache
    4. Reproduce the issue
    5. Stop recording
    6. Click the download button - (Export HAR appears when you hold the pointer over it.)
    7. Name the file
    8. Click Save
  • Once the .har file is available, you may need to compress it in a ZIP or WINZIP file and attach it to the case you are working on

Keywords

HTTP, HAR, Troubleshooting, SAP Cloud for Service , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2211