SAP Knowledge Base Article - Public

3290881 - Unable to close tickets in AskHR - Employee Central Service Center

Symptom

Employees are trying to close a ticket in AskHR, by clicking in the "Confirm" button, but nothing happens. 

Environment

  • SAP SuccessFactors HXM Suite
    • AskHR - ECSC

Reproducing the Issue

  1. Go to AskHR
  2. Select a ticket with Solution Proposed
  3. Click in "Confirm" button
  4. Confim the solution
  5. Nothing happens. Ticket is still in "Solution Proposed" state. 

Cause

Wrong ticket status configuration in C4C. ECSC does not supports custom codes.

Resolution

In order to identify the issue, you need to go to your C4C where the ticket status is configured and compare it with the Guide. 

Go to C4C > Business Configuration > Overview > Search for 'tickets' in the search > click in "Tickets for Employee Support" > Review configuration for 'Maintain Status Dictionary Entries' and 'Maintain Status Schemas'.

Configuration for the 'Maintain Status Dictionary Entries' should be as:

Status Code

Description

Life Cycle Status

Assignment Status

1

New

Open

Processor Action

2

In Process - By Agent

In Process

Processor Action

4

In Process - Waiting for Employee

In Process

Requestor Action

5

Solution Provided

Completed

Requestor Action

6

Closed

Closed

Not Assigned

Z6

Solution Confirmed

Completed

Requestor Action

If you have any different code for the "Solution Confirmed" button, such as: 7, Z1, Z2, Z3 etc. 

It won't work, since the only codes above are supported. 

For the 'Maintain Status Schemas', configuration should be as: 

Sort Sequence

Status

Life Cycle Status

Assignment Status

Initial Status

Status Visible

1

1-New

Open

Processor Action

CheckedChecked

2

2-In Process - By Agent

In Process

Processor Action

Checked

3

4-In Process - Waiting for Employee

In Process

Requestor Action

Checked

4

5-Solution Provided

Completed

Requestor Action

Checked

5

Z6-Solution Confirmed

Completed

Requestor Action

Checked

6

Closed

Closed

Not Assigned

 

All configuration must match the above tables. 

See Also

Implementing Service Center in Employee Central: Configuring Tickets for Employee Support

Keywords

ECSC, Service Center, Confirm solution, close ticket, AskHR, Confirm Ticket button is not performing any action, ticket status, status code, close askhr ticket, close ticket, AskHR error. , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem

Product

SAP SuccessFactors HXM Suite all versions