Symptom
Employees are trying to close a ticket in AskHR, by clicking in the "Confirm" button, but nothing happens.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to AskHR
- Select a ticket with Solution Proposed
- Click in "Confirm" button
- Confim the solution
- Nothing happens. Ticket is still in "Solution Proposed" state.
Cause
Wrong ticket status configuration in C4C.
Resolution
In order to identify the issue, you need to go to your C4C where the ticket status is configured, and compare it with the Guide.
For each ticket status in AskHR there is a code supported, as per the below:
Status Code |
Description |
Life Cycle Status |
Assignment Status |
---|---|---|---|
1 |
New |
Open |
Processor Action |
2 |
In Process - By Agent |
In Process |
Processor Action |
4 |
In Process - Waiting for Employee |
In Process |
Requestor Action |
5 |
Solution Provided |
Completed |
Requestor Action |
6 |
Closed |
Closed | Not Assigned |
Z6 |
Solution Confirmed |
Completed |
Requestor Action |
If you have any different code for the "Solution Confirmed" button, such as: 7, Z1, Z2, Z3 etc.
It won't work, since the only codes above are supported.
Please change the code to Z6 and the issue should be resolved.
See Also
Keywords
ECSC, Service Center, Confirm solution, close ticket, AskHR, Confirm Ticket button is not performing any action, ticket status, status code, close askhr ticket. , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem