Symptom
Error appears upon saving competency - Manage Center of Capabilities
Environment
Product version: SAP SuccessFactors HXM Suite Core 2211
Sold product: Successfactors Job Profile Builder
Reproducing the Issue
- Login to customer's instance
- Go to Admin Center > Manage Center Of Capabilities > Competencies
- Click on "Add"
- Fill in all required fields > Click "Add"
- Error pops up, "Sorry, we encountered a system error when validating entity \{0\} for correct formatting or to see if duplicate entities exist."
Cause
The problem is caused by MDF logic, the localeVsValueMap is empty which will generate the notifications. Currently user locale is set to English GB but the language is not defined.
Resolution
After switching to English US, the user should be able to create a new competency without any errors.
See Also
Keywords
localeVsValueMap, competency, error when validating entity, duplicate entities, manage center of capabilties , KBA , LOD-SF-TIH-JPB , Job Profile Builder , Problem