Symptom
Customer is passing values in a custom field which is not updating the employee detail in the business object view Employee.
Environment
Cloud for Customer.
Reproducing the Issue
- Open your Cloud for customer tenant.
- Go to Web Service Message Monitoring under Administrator Work center.
- Search for the Inbound Service Interface.
- Find the message ID and pen the Payload.
- Check if the KUT is correctly filled inside the Payload.
- Proceed to the respective Business Object View.
- Observe KUT field remains blank no value present.
Cause
Because the incoming payload was missing namespace value inside the KUT field string as it is incorrect in the WDSL.
Resolution
Ask customer to amend the inbound payload to have namespace added to the KUT fields. This can be complete by Re-downloading the WDSL file and uploading it to the relevant middleware.
Keywords
KUT field, Extension field, Custom Field, employee replication, WDSL, PDI, missing value, C4C, Payload, Namespace, , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem