SAP Knowledge Base Article - Public

3291052 - Deleting sales order in S4 does not trigger an outbound Idoc.

Symptom

Deleting Sales Order in S4 doesn't trigger outbound Idoc from S4, therefore Sales Order in C4C do not get deleted leading to data inconsistencies

Environment

  • Cloud for customer
  • SAP S4/HANA

Reproducing the Issue

  1. Open your S4/HANA system.
  2. Navigate to a Sales Order in the system via transaction code VA43.
  3. Delete a Sales Order.
  4. After deleting check the outbound Idoc's via transactions we02.
  5. Observe no outbound Idoc being triggered.

Cause

The deletion Idoc is sent out if one of the following pre-conditions are fulfilled:

1.)  A NAST entry is there for message type COD_REPLICATE_SALES_ORDER for the S/4 Sales Order.

2.) A binary relationship is created between the C4C sales order and the S/4 Sales Order. This relationship is created in S/4 in the following cases:

    a.) An S/4 inbound Sales Order replication happened.

    b.) An S/4 inbound Sales Order confirmation happened.

Resolution

Activate the outbound communication arrangement Sales Order Replication from SAP Business Suite in C4C to satisfy pre condition 2 above, or activate NAST entry for message type COD_REPLICATE_SALES_ORDER for the S/4 Sales Order.

Keywords

NAST entry, S4, sales orders, Deletion, synchronization, doesn't trigger, C4C, Idoc, Binary relationship, , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions