Symptom
Duplicate employee ID still present in the system whenever trying to search with the new employee ID or an Employee that is Inactive is appearing as Active for an Account.
Environment
SAP Business ByDesign.
Reproducing the Issue
There are many steps where you find the Employee is active
For Example:
- Go to Account work center
- Select contacts tab
- Choose Responsibilities, while adding a new row, with the name XYZ in the Employee with the help of the value help, it is showing XYZ as active.
i.e. XYZ is an Employee here.
Cause
Possible causes for the issue:
Case 1: There are 2 different employees with name XYZ which is causing this problem
Case 2: You have not used the re-hire functionality for employee instead you have used new hire.
Resolution
As per system design, for an employee employee ID always remains same even when the same employee is re-hired in the system.
To remove inactive Employee, follow the below steps:
- Go to the Business Partner Data work center.
- Go to Business Partner view.
- Click Action and select if you want to Block or Obsolete the Service Agent.
You can use Block usage to prevent further usage of these terminated employees.
Note:
This does not happen automatically. Therefore user must set this manually.
See Also
Keywords
Value help, Terminated Employee, Active, Service agent, Rehiring, Duplicate, Account, Still Appearing, Available, Appears. , KBA , service agent , value help , terminated employee , duplicate , rehiring , AP-BP-BPT , Business Partner Template , Problem