Symptom
An Account is not visible in Accounts Workcenter. However if we search for its Internal Object ID in Web Service Message Monitoring, we can see that its status is successful.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Access C4C.
2. Go to Administrator Workcenter.
3. Open Web Service Message Monitoring.
4. Search for the Account's Internal Object ID.
5. See the successful status.
Cause
Customer or prospect role missing in account.
Resolution
Account is not visible in Accounts workcenter because the business partner does not have a role provided in the payload.
In order to be able to see it under the Accounts workcenter, it either needs a customer or a prospect role.
Keywords
Account; Internal Object ID; Web Service Message Monitoring; Customer; Prospect; Role , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem
SAP Knowledge Base Article - Public