SAP Knowledge Base Article - Public

3291549 - Instance Refresh pairing error "An error has occurred. Please refresh the metadata cache in your source and target instances and try again. To refresh the metadata cache, go to Admin Centre > OData API Metadata Refresh and Export"

Symptom

Error is thrown when pairing on Instance Refresh Tool:

  • An error has occurred. Please refresh the metadata cache in your source and target instances and try again. To refresh the metadata cache, go to Admin Centre > OData API Metadata refresh and Export, and then choose Refresh. If you are still unable to generate the authentication token, please contact Product Support.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Access the instance
  2. Go to Admin Center 
  3. Search for "Instance Refresh"
  4. Select "Full Copy (Instance Refresh)"
  5. Click "Create New Request"
  6. Click "Add New Pair" > enter target instance details
  7. Click "Generate Token" > error is thrown

Cause

Possible causes:

  • If you select the wrong environment (e.g. preview instead of prod) you will also get this error
  • Metadata cache issue

Resolution

First scenario:

Make sure the correct environment (Production or Preview) is selected for the Company ID.

It is possible to have a Role type Test/Development in a Business type production, the Target instance Environment point to business type, Tenants with URL that does not contain "preview" means that business type is production.

Example of a non-productive environment where Target instance Environment is production.

Company ID: SapD01
Role: Test/Development
Business type: Production
URL:     https://performancemanager.successfactors[...]company=SapD01

Example of a non-productive environment where Target instance Environment is preview.

Company ID: SapT02
Role: Test
Business type: Preview
URL:     https://hcm[...]preview.sapsf.com[...]company=SapT02

Second scenario:

  1. Go to Admin Center > search for OData API Metadata Refresh and Export
  2. Perform a Refresh Metadata Cache (please follow the steps from KBA 2171588 - OData API Metadata Refresh and Export - SuccessFactors)
  3. After you perform the Refresh Metadata Cache please try to generate the token once again

If the above does not work, reach out to Product Support on LOD-SF-PLT-IRT component.

See Also

 2789795 - Instance Pairing lssue - The Application Encountered an Unknown Error

Keywords

instance refresh error, pairing error, IRT, refresh, odata, api, cache, error has occurred, production, preview, role, business type , KBA , LOD-SF-PLT-IRT , Instance Refresh Tool , Problem

Product

SAP SuccessFactors HXM Core 2211