SAP Knowledge Base Article - Public

3291829 - Field gets blank after import even not being part of the load - Employee Central

Symptom

When performing a job history import in incremental load mode, a custom field that is not included in the template gets blank in the portlet. The behavior is the same in case the expression "&&NO_OVERWRITE&&" is used for the field during the import.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Import Employee Data and import a template including only standard and mandatory fields for a user
  2. Go to the profile of this user and check the record recently imported
  3. The data was imported correctly, but the value of a custom field was deleted.

Cause

The custom field is configured in more than one country with the same code and different attributes. 

Resolution

The custom strings can be configured in more than one country, but they need to have the same configuration - it is not recommended to configure different picklists for the same custom string in different countries, for example.

To correct this issue, download the Country/Region-Specific Succession Data Model and check all the countries with the custom string configured. Make sure that all of them have the same configuration. If some change is required, please configure a different custom string to replace the existing one before removing it, as it is not recommended to change a custom field that is already in use. 

See Also

Keywords

import, blank value, field blank, field deleted, job history, &&NO_OVERWRITE&&, import employee data, ECT-197051  , KBA , LOD-SF-EC-EDP-JOB , Job Information Imports , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Suite all versions