Symptom
Request for Change templates are used with a scope item defined in the scope assignment block of the template. When creating a request for change from the template the scope item is not copied to the request for change.
Environment
SAP Solution Manager 7.2
Reproducing the Issue
- Create a Request for Change template in the CRM UI
- Define a scope item in the scope assignment block
- Release the template
- Create a Request for Change document from the template
- See that there is no scope item in the assignment block of the resulting request for change
Cause
- The copy control rules are incorrect
- The wrong transaction type was selected in the scope assignment block in the template
Resolution
Check the copy control rules
- Execute transaction code SM34
- Maintain cluster AIC_SETTINGS2
- Find the template transaction type (SMCT, ZMCT, etc.)
- Select "Copy Control Rules"
- Find the line that defines the rules for the target transaction type (SMCT -> SMCR, ZMCT -> ZMCR, etc.)
- Check that the column "Scope" is ticked
Check that the correct transaction type has been selected in the scope assignment block for the template
- On the CRM UI navigate to your template
- Scroll down to the scope assignment block
- Click the dropdown and check the options available
- If needed enable keys in the dropdown options (Click "Personalize" in the header -> Personalize settings > Tick "Show keys in dropdown lists")
- Check that the correct transaction type has been chosen
- For example if copy control rules do not allow SMMJ to be created from ZMCR then SMMJ should not be selected in the template. Instead if ZMCR -> ZMMJ is permitted ZMMJ should be used.
See Also
2636654 - How to configure Copy Control for follow-up transactions - SAP Solution Manager
Keywords
copy control rules, request for change, template, RFC, RFC template, charm, scope, assignment block, scope item, SMCT, ZMCT, SMCR, ZMCR, copy, solution manager, solman , KBA , SV-SMG-CM , Change Request Management , Problem