SAP Knowledge Base Article - Public

3292333 - Unable to receive emails coming from CPQ

Symptom

  • Not receiving password reset emails
  • New user did not received emails
  • Quote proposal is not received
  • CPQ is not sending notifications
  • Approval emails are not delivered
  • When "From Email Address" is set to @sap.com, email is not received, and if it is something different, it works.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  • Request the Password reset email by using Forgot Password option
  • Create a new user and send initial user creation email
  • Send Quote Proposal
  • Send Quote notifications
  • Send Approval emails.

Cause

Our internal infrastructure is not set the same way for all environments, which can cause issues when using the "From Email Address" or using it incorrectly. When the mail is sent from our servers, the mismatch between the from and SPF records can be caught by spam filters.

Resolution

CPQ Teams are working on a permanent fix for this issue, where changes will be made to the outbound mail from CPQ. As a workaround, we suggest to apply both settings: 

  1.  Perform whitelisting of SAP CPQ SMTP IP addresses according to your Datacenter:
    1. Adding IP address to company whitelist should be done by network team of your company.
  2. Setup DKIM Certification:
    1. Adding DKIM should be done in cooperation with network team and implementation team from of your company.

See Also

Keywords

Email, Mail, Spam, Filter, DKIM, SMTP, Outbound emails, SPF, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error

Product

SAP CPQ 2023