Symptom
During the rehire process one or more fields are not being populated automatically from previous employment.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Start the process of rehire through "Rehire Inactive Employee" or "Add New Employee (Accept Match)";
- Fill the required personal fields > Continue;
- Check that data (e.g. "Address") did not get populated automatically.
Cause
This is an expected behavior when there are rules configured to change the values.
Resolution
If you perform the rehire through "Rehire Inactive Employee" or "Add New Employee (Accept Match)", all the previous data must be populated automatically.
In case the rehire does not automatically populate the fields, it will be necessary to collect the logs and check if any rule is interfering in the process and setting other values for this fields.
In order to check it, enable Rule Trace and perform the steps from scratch so you can identify the rows with "[set]" information and raise the rules that are affecting the process. Please refer to KBA 2257064 - Employee Central - Business Rule Execution Log.
After analyzing the file, if you raise that some rule can be the cause of the issue, please try to disable the rule to confirm the behavior and contact your implementation partner as custom configuration is not under the scope of Product Support. Please refer to KBA 2801299 - What is Support - What is Consulting.
See Also
Keywords
rehire, rehire process, rehire inactive employee, add new employee, accept match, previous employment, populate, not populated, employee central , KBA , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , How To