Symptom
You are getting a health check incident with the subject: Health Check Assignment of type CRM_CQ_NTF_APPROVED BTM items not possible
Environment
Business ByDesign
Reproducing the Issue
- Go to the Application and User Management work center.
- Select the Business Task Management view.
- Show: Unassigned Items.
- Select the Business Task with the subject Quote XYZ Approved (XYZ represents the quote id).
- Open Application Log 11111111 (11111111 represents the Log number).
- You can see the following:
Business task is inconsistent - no valid responsible person/organization
Searching for responsible in non-configurable work category: Responsible person for Service Quote
Searching using method Responsible Person for Service Quote
Result:
Employee found: ABC (ABC represents the user name).
Employees without sufficient access rights for the item:
Employee: ABC.
Info: Work Center Views that potentially grant access:
View:Sales Quotes (CRM_SALESQUOTES) - Context: Sales (4)
No employee has sufficient access rights
Cause
The user ABC does not have the work center New Business and the view Sales Quotes assigned. Hence the task cannot be assigned to the user.
Resolution
You need to ensure that the user ABC has access to Sales Quotes or assign the task manually to a user that has the work center assigned and the respective access rights.
- Go to the Application and User Management work center.
- Select the Business Users view.
- Select user ABC.
- Click on Edit Access Rights.
- Go to the Assigned Work Centers and Views.
- Assign the work center New Business and the view Sales Quotes assigned.
Keywords
Sales Quote, Quote; CRM_CQ_NTF_APPROVED; Task; Unassigned , KBA , AP-CQP , Customer Quote Processing , Problem