SAP Knowledge Base Article - Public

3292620 - Unable to initiate background check - Http Error response code 500 - Recruiting Management

Symptom

  • Error occurs when attempting to Initiate Background Check: 'Unable to initiate background check. Error occured while executing integration center process.'
  • Integration Center Event Log: 'Http Error response code 500 with response state text: while calling url:  <Endpoint URL>'

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Click Take Action > Initiate Background Check
  2. It displays an error 'Unable to initiate background check. Error occured while executing integration center process.'
  3. Go to Integration Center > Monitor Integration
  4. The event log shows an error 'Http Error response code 500 with response state text:  while calling url: <Endpoint URL>'

Cause

The HTTP status code 500 is a generic error response that appears when there is no matching error information.

It is mainly a configuration issue. The error occurs if some of the mandatory fields or the values are missing in the background check request, e.g., Job Application ID, Account ID, Package ID etc.

Resolution

Please confirm with the vendor what are the minimum fields required in the background check request and make sure to pass values for those fields.

How to troubleshoot the issue (by taking the standard fields Account ID and Package ID as an example):

1. Check Account ID and Package ID on the Job Requisition Details page.

Note: The field names in your instance can be different. The Field ID of Account ID is "bgiAccountId" and Package ID is "packageId".

2. Check the field association of Account ID and Package ID in the integration

  1. Go to Integration Center > My Integrations
  2. Edit the integration
  3. Open Configure Fields tab
  4. Check if "bgiAccountId" and "packageId" are associated with the destination fields on vendor side

Note: The outbound data structure is provided by the vendor.

3. Make sure that Account ID and Package ID have valid values in the background check request

  1. Go to Integration Center > My Integrations
  2. Edit the integration
  3. Open Filter and Sort tab
  4. Expand Advanced Filters
  5. Select the field "applicationId" and specify the Application ID which background check initiation was failed
  6. Open Configure Fields tab
  7. Check the Preview on the right side and make sure the fields have valid values

*If the error persists, we recommend you provide this Preview payload (Step 7) to the vendor to check if anything else is missing in the background check request.

See Also

User Assistance Documentation:

Keywords

background check, error, integration, vendor, Orange Tree, Account ID, Package ID, bgiAccountId, packageId, field mapping, field association , KBA , LOD-SF-RCM-BCI , Background Check , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions