SAP Knowledge Base Article - Public

3292627 - System Owner privilleges lost after IDP setting

Symptom

Even as a System Owner, the features below are not visible to your account when accessing SAP Datasphere tennant after setting IDP for it:

  • Security -> Users
  • Security -> Roles
  • Security -> Activities
  • System - > Configuration
  • System - > Administration

Environment

  • SAP Datasphere

Reproducing the Issue

  1. Access the SAP Datasphere affected tenant;
  2. Check that the features mentioned in the symptom are not displayed in the left panel.

Cause

The reason for losing the system owner access, is that the IdP for tenant has been changed without adapting the login ID(E-mail) to be returned as login ID by the new IdP. Now you are logging with an different identity such as "USERID" which does not map to the original account.

Resolution

In order to restore the system owner access, you must setup the new IdP to return your E-mail Address as user ID.

See Also

Keywords

System, Owner, IDP, Security, System, Administration, Configuration, Activities, features, user, mapping, tabs, missing, SAML, SSO , KBA , DS-SEC , Security (Users, Roles) , Known Error

Product

SAP Datasphere all versions