SAP Knowledge Base Article - Public

3293038 - Application Log Instance Show “In Process” Even Though There is No Background Job Running

Symptom

Status of an Application Log instance show “In Process” even though there is no background job running and customer wants to delete it.

Environment

SAP Business ByDesign; Cloud for Customer.

Reproducing the Issue

  1. Go to Administrator WC
  2. Check the Mass Data Run view
  3. Check the RUN ID
  4. Check the application log still shows “In Process”

Cause

When a job execution fails with a dump or a timeout , the MDRO framework doesn’t get the control back from the application process in case of custom business object like PDI solution. Because of this, MDRO framework doesn’t update the status of the Application log and it is displayed as “In Process”.

Resolution

  1. You can find the correct status of the log, select the required MDRO instance.
  2. Click on “View Jobs”
  3. Select “Run Jobs” from the “Schedule Jobs” drop down. 
  4. The status of the job tells you the correct status. Its finished or failed.

To avoid situations like these, make sure you handle the MDRO’s action logic to avoid dumps. You can also achieve this by handling the “Avoid Dumps” suggestions from the “Performance Tips” on the action absl logic and try to get avoid this in process job log status.

See Also

You can refer to the SAP Cloud Application Studio help documentation MDRO section for more details.

Keywords

MDRO;JOB;INPROCESS;FAILED JOB , KBA , AP-RC-BDS-MDR , ByDesign Studio Mass Data Run , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions