SAP Knowledge Base Article - Public

3293063 - Unable to send DocuSign offer letters - user stuck in consent loop - Recruiting Management

Symptom

During offer letter process using Online Offer with eSignature, the user is stuck in a "Missing Consent" loop.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. During the Offer process the recruiter click on "Online Offer with eSignature".
  2. The pop-up message "Missing Consent" appears, then click on "Continue".
  3. DocuSign Log In page for authentication appears.
  4. Successful message from DocuSign "You've completed the one time DocuSign consent agreement" appears.
  5. However if you try again "Online Offer with eSignature" the same "Missing Consent" appears again in a loop.

Cause

  • DocuSign User ID mismatch. The PARTNER_USERNAME in SuccessFactors is different from the User ID in DocuSign, or multiple user profiles are associated with the same email address in DocuSign.
  • DocuSign admin account mismatch. The user's DocuSign account is not associated with the DocuSign admin account configured in Manage Recruiting Settings.

Resolution

Steps to fix the DocuSign User ID mismatch

DocuSign:

  1. Log in to DocuSign as admin.
  2. Go to Settings.
  3. Select Users from the left navigation menu.
  4. Change the search option to 'Email' and enter the user's SF email address.
  5. Click Search.


    *Assure that only one Active user is present for the user’s email id. If there are more than one active accounts, identify duplicate users which need to be closed and use the ACTIONS button to close those duplicate users.

  6. Open the active account.
  7. Note down the User ID xxx-xxx-xxx-xxx-xxx.


SuccessFactors:

  1. Go to Manage External User Accounts.
  2. Select Export all external accounts to export the file.
  3. In the file, filter with EXTERNAL_PARTNER_CODE = RCM_DocuSign.
  4. Check the column PARTNER_USERNAME of the user. It should be the same as the User ID in DocuSign.
  5. If the PARTNER_USERNAME is different, enter the correct User ID in the file.
  6. Go to Manage External User Accounts.
  7. Select Import External accounts to import the file.


Steps to fix the DocuSign admin account mismatch

DocuSign:

  1. Log in to DocuSign as admin.
  2. Go to Settings.
  3. Select Apps and Keys from the left navigation menu.
  4. Obtain User ID and API Account ID.


SuccessFactors:

  1. Navigate to the DocuSign eSignature section in Manage Recruiting Settings.
  2. Ensure that DocuSign User ID and DocuSign API Account ID are consistent with the information in DocuSign.

See Also

Keywords

RCM, DocuSign Integration, Offer, Missing Consent, loop, repeated , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions

Attachments

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