SAP Knowledge Base Article - Public

3293080 - Why do I receive an error 401 message in the Postman console when posting data from Postman to PI using the Ingestion API?

Symptom

Why do I receive an error 401 message in the Postman console when posting data from Postman to PI using the Ingestion API?

Environment

SAP Signavio Process Intelligence 3.0

Reproducing the Issue

  1. Open Process Intelligence.
  2. Create a new Data Source.
  3. Select an Ingestion API.
  4. Open Postman.
  5. Click on Headers.
  6. Input the Accept, Content-Type and Authorization values as per the documentation: https://documentation.signavio.com/suite/en-us/Content/process-intelligence/ingestion-api.htm 
  7. Paste the API endpoint into the url box.
  8. Select the Post request.
  9. Send the request 
  10. See you receive the Error 401 'Access Denied'.

Cause

Under the Authorization tab the default value of 'OAuth 2.0' is the incorrect authorization type for this API request.

Resolution

Under the Authorization tab, change the authorization type selected from 'OAuth 2.0' to 'Bearer'.

See Also

For more information on the Ingestion API, please read the following excerpt from our user guide: https://documentation.signavio.com/suite/en-us/Content/process-intelligence/ingestion-api.htm

Keywords

process, intelligence, ingestion, api, error, 401, access, denied, postman, authorization, authentication , KBA , BPI-SIG-CA-API , REST-API for SAP Signavio , Problem

Product

SAP Signavio Process Manager 3.0