Symptom
You are facing the error message "<Language> description missing" for a particular language, which may be Chinese, French, and so on, during replication of registered products to C4C.
Environment
Cloud for Customer
Reproducing the Issue
- Replicate data from external system to C4C.
- In C4C, go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration
- Select query All
- Search for the most recent incoming web service message.
Error: Error while processing inbound third party communication | <Language> description missing
Cause
Verifying the payload you may face:
<Description actionCode="04">
<Description languageCode="AB"/> (where AB means the language code)
</Description>
So, the error is raised due to the missing description in the incoming payload, since it is mandatory for Registered Products in C4C.
Resolution
In order to resolve such issue you can evaluate both approaches:
- In the middleware, you can set the LCTI descriptionListCompleteTransmissionIndicator="false"
- In your external system, please maintain the description for the registered product.
See Also
Keywords
C4C, <Language> description missing, RegisteredProductReplicationInitiatedByExternalIn, description , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To