SAP Knowledge Base Article - Public

3293543 - Boomi process fail for Job requisition Upsert with Division / Location / Department.

Symptom

When try to run the Boomi process for Job Requisition Upsert for NON-EC system and getting below error. Where Division / Location / Department are define as Enum value.

Error:-

Casenumber: XXXXXXX
Requisition template: Global Requisition
Error : [APPLICATION_ERROR] Operation complete with application error: Location value "ABC" is not mapped to values in the system

  • Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
    • Integrations
      • Boomi Process
        • Boomi to SF upsert 

Reproducing the Issue

1. Run the Boomi Process for creating Job requisition in the system.

2. Process has below Payload for upsert.

Kindly check on this issue and share your inputs.

XML Data : <?xml version='1.0' encoding='UTF-8'?>

<JobRequisition>
<originator>xxxxxx</originator>
<guid>5005a00002M1t1iAAB</guid>
<title>ABC : Supervisr III - Cementing</title>
<extTitle>Service Supervisr III - Cementing</extTitle>
<status>Pending Approval</status>
<numberOpenings>2</numberOpenings>
<jobCode>Supv III-Cementing (4900)</jobCode>
<classificationTime>Full Time</classificationTime>
<cust_employeeGroup>Agency</cust_employeeGroup>
<cust_univeityRequisition>No</cust_universityRequisition>
<location>ABC</location>
<cust_classificationType>Direct</cust_classificationType>
<customCompany>1000 </customCompany>
<cust_location>ABC - W150</cust_location>
<cust_jobLocation>1 st street, SC 100</cust_jobLocation>
<city>XYZ</city>
<filter3>ABC</filter3> 
</JobRequisition>

3. The values for the standard fields Division, Department, and Location in the Job Requisition  

4. Get the below error.

Casenumber: XXXXXX
Requisition template: Global Requisition
Error : [APPLICATION_ERROR] Operation complete with application error: Location value "ABC" is not mapped to values in the system

Cause

This is expected behavior from System.

Resolution

To resolve this issue please follow below.

  • The values are not pulled from Employee Central and there is no relation with the information under Admin Centre > "Manage Data".
  • Values for the standard fields Division, Department and Location are pulled from the User Directory which can be downloaded using Admin Center > Employee Export (Here you can check all the values under the Division, Department, and Location columns to see that they match the values in the job requisition.)
  • The values for both active and inactive users are taken into account in the job requisition.
  • Inactive users are included because potentially they can be converted into active users at a later date.
  • If you don't have EC in the system Please navigate to "Manage Users" in that for any dummy user add the new entry (in this case ABC) of location.

For example: if a recruiter cannot find a location in the job requisition detail, it is because that specific location is not associated to a user in the user directory.

Note: If there are more than 100 values for these fields, the [Custom Select] option appears next to the field. This option displays automatically based on the number of values in the field, and only applies to the standard enum fields. This is not configurable.

See Also

https://launchpad.support.sap.com/#/notes/2308880

https://launchpad.support.sap.com/#/notes/2718804

Keywords

Enum, Boomi, mapped, field, department, division, location, transferred, template, behavior, User Directory, file Employee Export, missing location , KBA , LOD-SF-INT-BPI , Dell & Boomi Infrastructure , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , Problem

Product

SAP SuccessFactors HXM Core 2211 ; SAP SuccessFactors HXM Suite 2211