Symptom
While trying to purge employee data from inactive employees, customer gets this error message "ECDataUserObjectType EC data user purge failed. Please check server log or create a ticket.".
Environment
SAP SuccessFactors HCM Core
Reproducing the Issue
- Log onto affected system with provided support access.
- Go to Data Retention Management.
- Create a new purge.
- Select 'Purge Inactive User'
- Select users/provide upload file of users to be purged.
- Submit purge.
- Go to Purge Request Monitor.
- Approve the purge.
- Go to Purge Progress & Results.
- Download the report and see the error: "ECDataUserObjectType EC data user purge failed. Please check server log or create a ticket." for the failed users.
Cause
Enable OpenText Integration was enabled in provisioning when third party storage was not being used causing issues with the purge.
Resolution
Disable Enable OpenText Integration in provisioning ---> Company settings.
See Also
- 2518360 - The Manage Documents Feature in SAP SuccessFactors - SAP for Me
- 2615360 - Data Protection and Privacy - Data Retention Time Management (DRTM) - Master Data Purge for Inactive Users - SAP for Me
- 2545988 - How to Purge/Delete users in SuccessFactors
- 3058601 - How To Check Soft or Permanent Purge User
- 2545988 - How to Purge/Delete users in SuccessFactors
- 3058601 - How To Check Soft or Permanent Purge User
Keywords
sf, success factors, document, document management, manage documents, DRTM, PLT, DRM, purgeGroup, Purge Object Group, Inactive User Purge, error, ECDataUserObjectType EC data user purge failed. , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , Problem