Symptom
When user tries to open Sales Quote in C4C, error message is displayed: "User does not have permission to view this quote."
Environment
Type: Test and Productive Systems connected with Cloud for Customer
Product version: SAP CPQ 2023
System managed by: SAP Cloud Tenant
Sold product: SAP SALES CLOUD CPQ
Reproducing the Issue
- Open Sales Quote in C4C;
- Error displays.
Cause
Incorrect configurations in Workflow.
Resolution
For being able to open a quote, the user should consider the relation with the specific quote (meaning if they are the owner, approver or a third part).
- If user is owner, Workflow settings for "My Quotes" is considered;
- If user is approver, Workflow settings for "Waiting for Approval" is considered;
- If user is a third part, Workflow settings for "Other Quotes" is considered;
This settings are defined by business case, and basic configuration should consider adding actions "view" and "edit" to the expected start/end status.
See Also
- Workflow permissions - https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/4776340d6aa74875bffd39388e48098d.html?version=latest
- Workflow - https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/50fc3151211f479d910cbcf295f77dc9.html?version=latest
- Access Rights - https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/38f993341de84159a783ce72e6ae9666.html?version=latest
Keywords
Workflow, Permission, View, Edit, Open Quote, Sales Quote, C4C, CPQ. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , LOD-CRM-INT-CPQ , Integration of C4C with CPQ , Bug Filed