SAP Knowledge Base Article - Public

3294332 - Chat Integration: Image cannot be opened at C4C Transcript window

Symptom

Image sent from customer during a Chat session (for example when using WhatsApp) cannot be opened at C4C Transcript window

Note: Image can be seen at widget integration during the Chat session

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service
  • SAP Cloud for Sales 

Reproducing the Issue

  1. Select the corresponding Service Ticket number
  2. Open Timeline facet
  3. Open View Transcript where you can find the conversation with the customer
  4. Select the image file name (for example 123456789.jpg) at Transcript window

Cause

SAP Service Cloud supports only plain text for transcripts

Resolution

- Your external communication system must convert transcripts to plain text before uploading.

- To retain rich text in transcripts, output the transcript as an Adobe Acrobat format (PDF) document and add the file as an attachment to the corresponding activity.

- Refer to Chat Attachment help section

Keywords

Image photo WhatsApp Chat JPG Transcript Timeline file , KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer core applications 2211