Symptom
- Candidate disappeared after accepting as Rehire.
- In BPE Monitor can see can see Onboarding2Workflow or Onboarding2AtsIntegrationWorkflow entered exception message
Environment
SAP Successfactors Onboarding
Reproducing the Issue
- Complete Personal Data Collection
- Add an attachment in Payment Information portlet
- Submit Personal Data Collection
- Candidate enters Perform Rehire Verification
- Accept rehire on new employment
- Candidate disappears and cannot be located in dashboard
Cause
- Attachment uploaded in Payment Information portlet during Personal Data Collection is causing candidate to enter exception message.
- The attachment is failing as it cannot merge with the rehire flow
Resolution
- Engineering team are aware of this issue and investigating further to resolve.
- They have a tentative release date for permanent fix of 2H 2023 Release. Please be aware this is tentative date and could change.
- Workaround:
- Admin center -> Manage data -> search Payment Information - > Search with User id of affected candidate - > select the user.
- Click Take action
- Delete the supporting doucment attached.
- Post deletion of this supporting document, save the Payment information
- Go to BPE : Manage Process Task -> filter to find process instance which is stuck -> then click on Restart Task.
- If you have candidate which is currently stuck could you please try this workaround .
- Where no attachment was uploaded no exception message is found as payment information can merge with rehire.
Keywords
LockId is already set, update is not allowed, attachmentId=1234, status=null, attachment, payment information, rehire on new employment, exception message, candidate disappears after rehire, OBX-25603, EMPLOYEE_HRIS_GO_DMS_ERROR_LOCKID_ALREADYSET , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem
Product
SAP SuccessFactors Onboarding 2211