SAP Knowledge Base Article - Public

3294602 - Products from C4C not copied to CPQ Quote

Symptom

Product is not being saved on CPQ Quote during Quote creation on C4C. 

Environment

SAP SALES CLOUD CPQ integrated with SAP Cloud for Customers

Reproducing the Issue

  1. On C4C Create a new Quote;
  2. Search for a product and add to the quote;
  3. Click on Save and Open;
  4. Product will not be on Quote.

Cause

On Payload ProductSystemID is not being sent to CPQ. 

Resolution

ProductSystemId is used when finding product to add in SAP CPQ. If an empty ProductSystemId is given, such products are ignored.
Customer should configure their payload with needed information in order to CPQ recognize the product and then add it to the quote.

See Also

Keywords

Quote 2.0, C4C, Integration, Cloud for Customer, Product, Quote, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ 2023