Symptom
Product is not being saved on CPQ Quote during Quote creation on C4C.
Environment
SAP SALES CLOUD CPQ integrated with SAP Cloud for Customers
Reproducing the Issue
- On C4C Create a new Quote;
- Search for a product and add to the quote;
- Click on Save and Open;
- Product will not be on Quote.
Cause
On Payload ProductSystemID is not being sent to CPQ.
Resolution
ProductSystemId is used when finding product to add in SAP CPQ. If an empty ProductSystemId is given, such products are ignored.
Customer should configure their payload with needed information in order to CPQ recognize the product and then add it to the quote.
See Also
- Items in SAP CPQ - SAP Cloud for Customer Integration for Quote 2.0 - https://help.sap.com/docs/SAP_CPQ/0fd304e6b1fc46e18fbead1f2c908f8e/b09b928637bf4e6cb550c0611ae488b9.html?version=latest
Keywords
Quote 2.0, C4C, Integration, Cloud for Customer, Product, Quote, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ 2023