Symptom
You are creating a manual invoice request or an intercompany scenario and upon entering the item to the document, the system returns the error informing that the tax region is missing for item 10.
ABC represents the ID of the country displayed in the error message.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer invoicing work center.
- Select New Manual Customer Invoice from the Common Tasks.
- Enter the account ID FGH (FGH represents the ID of the account).
- Click Add Row.
- Enter item XYZ (ABC represents the ID of the product/service).
Error: Tax region for country ABC in item 10 is missing. You have to set the tax jurisdiction code manually on the Taxes tab.
In this case we have taken examplet of customer invoice but similar error can be seen in the intercompany sales order as well when the Seller's address is not maintained completely/inconsistent.
Cause
The reason the system is generating this error is because the Seller's address is inconsistent/incomplete.
Resolution
This is the system expected behavior.
Please maintain the complete address for the seller party and create a new manual invoice.
See Also
3037882 - Error Occurs When Entering a Product in a New Manual Invoice for an Account Located in Canada
Keywords
Error, Tax, Region, Manual, Invoice, Invoice Request, Entering, Jurisdiction, Intercompany, Tax Jurisdiction, Sales Order , KBA , AP-CI-CI , Customer Invoice , How To