SAP Knowledge Base Article - Public

3294776 - Unable to download a Report from the Report Module containing bulk data. Error: "An error occurred while processing your request."

Symptom

  • You are unable to download a certain report in Excel format without using any filters.
  • You're getting error "An error occurred while processing your request.".
  • You would like to download all the data in bulk.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Go to Setup
  2. General
  3. Report Module
  4. Look for your Report
  5. Click on the View button
  6. It times out in some time and we see error "An error occurred while processing your request.".

Cause

    • Looks like the issue is with the Report's DB query, it's timing out which is why error is occurring only for certain reports.
    • Maybe that DB query worked before when the number of records in DB was lower.
    • If the query is not optimized, it can happen that at some point it takes too much time to load all records.
    • If the SQL query of the Report runs more than 60 seconds then it will timeout after 60 seconds.
    • But if you pulled data from DB but other processing in the application takes additional time, then the timeout can occur after 20 minutes.
     
     
     

    Resolution

    • The workaround here would be for you to create a couple smaller reports by applying filters and then merge two excel files later to have all the bulk data.
    • Report Module is in maintenance mode so we unfortunately cannot consider any improvements in this case.

    Keywords

    report, report module, error, bulk data, filters, excel format, export, RM, merge, timeout, results, download , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

    Product

    SAP CPQ 2020