SAP Knowledge Base Article - Public

3295534 - US I-9 Compliance Unable to Fetch Form Data Error workaround solution - Onboarding

Symptom

  • Candidate is receiving an error when trying to start US I-9 Compliance Section 1 - Unable to Fetch Form Data
  • Customer does not want to enable the areaCode field in Manage Business Configuration due to their business requirement
  • Is there a workaround that the customer can use instead of enabling the Area Code field in phoneInfo entity?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login as the candidate
  2. In the Compliance Card, start the US I9 compliance task
  3. The 'Unable to fetch form data' appears.

Cause

  • After the 2H 2022 release, we updated the Form I-9 Section 1 verification step so that it now includes the complete phone number (including area code) collected in the personal data collection step.
  • If the format is incorrect, we've added a validation message that prompts the new hires to enter their phone number in the correct format. Hence, Area Code should be enabled.

Resolution

There are some customers who do not want the field to be enabled. There is a workaround available they can configure to bypass enabling the areaCode field in Manage Business Configuration.

Follow the below configuration:

  1. In Manage Data > Click 'Create New'
  2. Enter FieldMetaOverrideConfiguration
  3. Enter ID as whatever you prefer. In the below sample configuration, we used 'I9PhoneNumber'
  4. Change the overrideFields value to 'Yes'
  5. In field supportedTypes enter 'US_I9'
  6. In field metaOverrideType select the option 'Form Metadata Override'
  7. In the section overrideFieldMetadatas for the field id, enter 'phoneInfo.areaCode'
  8. In the field source, select the option Prepopulated Employee Central Fields Metadata
  9. Leave the field oldFieldsMeta blank
  10. The overrideFieldsMetadata will be as below:

    {
    "entity": "phoneInfo",
    "entityPath":"personNav/phoneNav",
    "field": "phoneNumber",
    "filters": {
    "phoneType":"DISABLED"
    }
    }

NOTE: We need to specify "phoneNumber" despite we are overriding areaCode as it is done on purpose. See attached screenshot of the configuration.

Once this is done, the error will disappear when the candidate starts the US I9 Compliance task.

See Also

Onboarding I9 Process failing due to missing area code in phone number field (USA Compliance Process only)

3264952 - [Onboarding] Unable to Fetch Form Data Error for USA I9 Compliance form after 2H 2022 Release

Keywords

areaCode, US I9 Section1, US I9, I9, Compliance Task, Compliance, US Compliance, FieldMetaOverrideConfiguration, Unable to fetch form data, error, Onboarding, ONB2, Onboarding2.0, ONB2.0, ONB, OBX , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding 2211