Symptom
In a knowledge base integration with SAP SuccessFactors Work Zone, while searching for a keyword in Search Knowledge Base tile in Ask HR application, following error pops up
Knowledge Base server is down. Please try again later.
HTTP Status 500 - An internal application error occurred.
Environment
SAP SuccessFactors HXM Suite
Ask HR application
Reproducing the Issue
1. Click Ask HR icon on top right corner of the employee home page in SFSF
2. On the pop-up window, click "Search Knowledge Base" tile
3. In the search bar enter random word say 'maternity' and hit on magnifying glass for system to initiate search
4. ERROR message is displayed as mentioned in the Symptom section
Cause
Incorrect Token Service URL configured under sap_workzone_odata destination in SAP BTP Cockpit.
Resolution
The format of the Token Service URL is https://<your SAP Work Zone URL>/api/v1/auth/token
If Custom Domain is configured under SAP Work Zone - Administration Console --> Overview, then Token Service URL would be like
https://<Custom Domain URL>/api/v1/auth/token
See Also
Implementation Guide: Implementing Service Center in Employee Central
Keywords
knowledge, base, server, down, http, status, 500, sap_workzone_odata, Ask HR, search , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem