SAP Knowledge Base Article - Public

3295558 - "Knowledge Base Server is down" error pops up while searching for a keyword in Search Knowledge Base tile in Ask HR application

Symptom

In a knowledge base integration with SAP SuccessFactors Work Zone, while searching for a keyword in Search Knowledge Base tile in Ask HR application, following error pops up

Knowledge Base server is down. Please try again later.
HTTP Status 500 - An internal application error occurred.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
  • Ask HR / Employee Central Service Center (ECSC)

Reproducing the Issue

1. Click Ask HR icon on top right corner of the employee home page in SFSF
2. On the pop-up window, click "Search Knowledge Base" tile 
3. In the search bar enter random word say 'maternity' and hit on magnifying glass for system to initiate search
4. ERROR message is displayed as mentioned in the Symptom section

Cause

Any missing or wrong configuration can potentially cause this error, see below examples:

1) Incorrect Token Service URL configured under sap_workzone_odata destination in SAP BTP Cockpit.

2) Incorrect Default Name ID Format configuration in Work Zone.

Resolution

1) The format of the Token Service URL is https://<your SAP Work Zone URL>/api/v1/auth/token

If Custom Domain is configured under SAP Work Zone - Administration Console --> Overview, then Token Service URL would be like

https://<Custom Domain URL>/api/v1/auth/token

2) As per the Implementation Guide the Default Name ID Format must look exactly as below:
urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified

See Also

Implementation Guide: Implementing Service Center in Employee Central

Configuring SAP SuccessFactors Work Zone as a Knowledge Base

Please make sure the Implementation Guide has been followed meticulously as any deviation from the guide could result in the above error. Review with your Implementation Partner before raising a ticket for Product Support.

Keywords

knowledge, base, server, down, http, status, 500, sap_workzone_odata, Ask HR, search, ECSC, work zone , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem

Product

SAP SuccessFactors HCM Suite all versions