SAP Knowledge Base Article - Public

3295938 - E-mail Field is Not Available As Advanced Search Criteria of 'Contacts With Account' Query of 'Add contacts' Pop-Up Inside Target Group

Symptom

You are adding contacts to a target group using the 'Contacts with Account' query and you noticed that the e-mail field is not available as advanced search field. You possibly noticed that it is available in the 'Contacts without Account' query.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales Campaign work center.
  2. Open the Target Groups view.
  3. Open Target Group ABC (where ABC is the ID of a target group).
  4. Go to the Members view.
  5. Click in the Add button and select the Contacts option.
  6. Select the 'Contacts with Account' query.
  7. Open the advanced search icon.

You do not see the 'e-mail' field to be used as search criteria.

Cause

For contacts with account, the meaningful e-mail address is the one that appears inside the 'relationships' view of the contact in the 'Is contact person for' entries (that tie the contact to an account). Relationships are stored in a different business object (BO) than the contact itself, thus the advanced search of contacts cannot look into this other BO.

Resolution

This is the system current standard behavior. This should not change as seen in this Customer Influence Request where we see the Product Managers comments 'Product strategy - will not be developed'.

Keywords

E-mail ; Advanced ; Search ; Query ; Contacts With Account ; Contacts Without Account ; Add Contacts ; Target Group; Missing ; Not Available ; , KBA , LOD-CRM-MKT-TG , Target Groups , LOD-CRM-CON , Contact , How To

Product

SAP Cloud for Customer add-ins all versions