SAP Knowledge Base Article - Public

3296538 - Step is being reassigned to another user - Onboarding 1.0

Symptom

Signature Step or any other step is getting reassigned from one user to another.

Environment

SAP SuccessFactors Onboarding 1.0

Cause

  1. Manager does not have permission
  2. There is a Assign Option
  3. There is an Assign Action

Resolution

For scenario 1:

  1. Go to Onboarding > Security > Groups
  2. Select the Group > Assign permissions
  3. Make sure the user has permission for the specific step requested

For scenario 2 and 3:

  1. Check Super Admin configurations
  2. Go to Affected step
  3. Check if there are "Assign Option" that is changing the assignee
  4. Check if there are "Assign Actions" that is modifying the assignee's key

In such cases, do the troubleshooting steps:

  1. Go to Onboarding > Audit trail and check the activity, the time stamp of the reassign 
  2. Check if the user has permission group and step on Security Groups
  3. It is also possible to check in Audit trail with Event Code "USER_GROUP_CHG" when the user has been added/removed from the groups
  4. Check in Super Admin > Data History > the history of the key, if for example the key is question is HiringManager, check the history of this key.
    • If the key value change the activity will be reassigned based on key value

Keywords

Reassign, Assign, Task, Onboarding, Onb, Obd, Activity, Current, Assignee, Named, User, Without, Perm, Access, General, Reassigned, Step, Super, Admin , KBA , LOD-SF-OBD-ADM , Admin Tools, Settings, Permissions , Problem

Product

SAP SuccessFactors Onboarding all versions